Back to overview
Downtime

Connections Issue with Cloudflare.

Jun 20 at 07:08pm UTC
Affected services
Webpage
API
Mist Client

Resolved
Jun 20 at 08:13pm UTC

Cloudflare pushed an fix and are currently monitoring for any further issues. But it seems our DNS is back up so Mist is up again!

Created
Jun 20 at 07:08pm UTC

Our database is hosted in EU and most of the EU lost connections with Cloudflare where we have our DNS setup.
So our services are out of service until Cloudflare resolves their issue.
More information here:
https://www.cloudflarestatus.com/incidents/p7l6rrbhysck