Back to overview
Degraded
New bugs have been reported
Apr 22 at 06:59am UTC
Affected services
Mist Client
Resolved
Apr 23 at 03:51pm UTC
The new patch is released!
Affected services
Mist Client
Created
Apr 22 at 06:59am UTC
Users haven't been able to launch Mist because of a 500 error.
We are trying to identify the issue
Affected services
Mist Client