Back to overview
Degraded
Multiple Bugs have been reported.
Apr 08 at 02:39pm UTC
Affected services
Mist Client
Resolved
Apr 21 at 12:22pm UTC
Forgot to update this XD
Affected services
Mist Client
Updated
Apr 14 at 11:51pm UTC
A new patch should be soon available!
Affected services
Mist Client
Created
Apr 08 at 02:39pm UTC
We are currently checking what causes these bugs.
Affected services
Mist Client